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Scope

This guide covers known requirements and instructions to configure the System Galaxy software to
integrate with 3 Party Video Plugins.

SG 10.5.6 Introduced LENSEC Perspective VMS and Video Insight 7 plugins.
SG 11.0.2 introduced DW Spectrum and Discovery OWS plugins.
SG 11.1.0.2 introduced WiseNet Wave plugin.

Always consult the manufacturer’s documentation for requirements and capabilities related to the
product (i.e. OS, install/set up, speed, bandwidths, camera models and features, codecs, etc. ).

The availability of features, cameras, video controls etc. are controlled by the 3" Party Plug-ins and may
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Revision History —

|_Date | Revisions | Descriptions |

JAN 2018 135((;'513“?02‘ (RY) This guide provides setup information for 31 Party VMS using the Video-API Plugin to connect and call-up video from
within System Galaxy (SG).

e LENSEC PVMS integration is added to the SG Video API Plugin. This integration requires the SG Client to have full user
rights to all cameras. NOTE SCREEN SHOTS USE LENSEC AS EXAMPLE. ALL ARE SIMILAR.

For general instructions on the operation and behavior of System Galaxy's Video Viewer, reference the general SG DVR Guide. The
main DVR guide covers how to call video from various locations in System Galaxy Client (i.e. events, reports, devices, alarms, etc.).

MAR2018  SG10.56(R5)  Added Video Insight 7 VMS Video-API Plugin solution to the table / instructions.
SEP2018  SG11.0.2(R6)  Added Discovery OWS and DW Spectrum Video-API Plugin solutions to the table / instructions.

APR2019  SG11.1.02(R7) | Added WiseNet Video-API Plugin solution to the port table / instructions.
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Chapter 1: Overview & Requirements
This guide covers how to install and set up Video Plugins to integrate video systems (VMS/NVS) with SG Video Viewer.

Galaxy’s Web API Video Plugin Solution allows 3%° Party VMS Manufacturers to create video api plugins that integrate
their Video Systems with System Galaxy using the GCS Web API Service.

Once the 3rd Party Plugin files are installed and System Galaxy is configured, the SG Operator can launch the 3rd Party
Video Viewer from within SG and view live or recorded video. The live and recorded video is retrieved using the same
operator commands and call-up rules that apply to traditional DVR method.

SUPPORTED FEATURES

The following lists supported features using the Galaxy embedded video viewer.
e play live video from a camera-linked device (reader or input in the hardware tree, graphic icon, alarm event)
e play live video from a selected camera (from hardware tree, graphic icon, alarm event)
e auto pop-up live video (from an alarm event — configuration required)
o the embedded Video Viewer supports the playback controls written by the 3™ Party producer.
e single camera view and multi-camera grid.
e Pan /tilt / zoom / speed / focus / presets / controls

NOTICE: Appearance & available controls of 3™ Party Video Viewers (i.e. style, PTZ, presets, iris, speed, etc.) will vary from
brand to brand, based on the designs implemented by 3™ Party developers. See List of Features table for more info.

SUPPORTED FEATURES
SG Video Viewer supports live and recorded video and can be launched from a camera-linked device (reader or input).

1. Video Viewer auto-launches (Live Video) when triggered by incoming alarm events (configuration required).

2. Video Viewer manually launches (Live Video) when the Operator invokes the ‘View Video’ command from the Hardware
Tree, the Device Graphic screen, Alarm Event window, or recorded playback from an Event Report screen.

FIGURE 1 - SYSTEM DIAGRAM: System Galaxy integrated with a Video Management System

System Galaxy

Atcess Control System VIDEO MANAGEMENT SYSTEM
< WEB API INTERFACE >
—| ‘SOFTWARE-LINKED’ CAMERAS
Event Monitoring Client-Workstation PROVIDE INSTANT LIVE VIDEO PARKING LOT (CAM 1)
FROM INCOMING ALARM EVENTS*
e 8 *CONFIGURATION REQUIRED . E>_
DOORS -
« Back Door (1) * FRONT DOOR (CAM 2)
T GALAXY 635
! I T ACCESS CONTROL PANEL ® Front DoOr (2) wewemssanes
: - o Lobby Door (3) ..,
AT LOBBY AREA (CAM 3)
Galaxy Comm. Server + DVR ENABLED i 7, e
v AUTO-POP ON ALARM WEB-API VIDEO VIEWER 2
LIVE VIDEO for linked cameras INPUTS. -
when ‘auto-popup’ alarm triggers*. o Lobby Motion (1)
LIVE & RECORDED VIDEO for ® MD Hi-Sec. Area

<(GCS SERVICES RUNNING the selected cameras, on-demand.
GCS CLIENT GATEWAY, e INPUT 3

GCS WEB-API SERVICE, (...

WEB-BASED VMS

ETHERNET NETWORK

Supported Video Plugin Solutions

3RD Party Video-Plugin Solutions Galaxy OEM Solutions
e LENSEC Prospective VMS (PVMS) e Discovery OWS (OEM) NEw
e Panasonic Video Insight 7 VMS (V17) NEw
e DW Spectrum IPVMS NEW
e WiseNet Wave NEw

& see the SG DVR Guide for “PC-based Video Solutions”, which include OEM and 3 Party Solutions.

O SUPPORT: Consult authorized Tech Support for newer Video API Solutions, since new plugins are added periodically.
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Table of Features for Plugin- enabled Video Viewers

VIEWER CAMERA FUNCTIONS(1) VIDEO & CAMERA CONTROLS (2) RECORDED VIDEO FUNCTIONS (2)
SUPPORTED VIEWERS* ! ** APl o en  IMPORT  MULTI-CAM PTZ FOCUS PRESET SEARCH PLAYBACK CTLS.
VIEWER CAMERAS GRID VIEW SPEED + IRIS CLEAR / SET RANGE (PB. CLOCK/RATE)
LENSEC Prospective VMS YES YES FOCUS FROM START
(default port = 8085) PVMS o YES YES IN SETTINGS onty  PRESETONLY | fre - TiME YES
Panasonic Video Insight 7 YES FOCUS FROM START
(default port = 9000) YES o YES YES IN SETTINGS ony  PRESETONLY | pre - TiME YES
DW Spectrum FROM START
(default port = 7001) YES -- YES YES YES DATE - TIME PLAY
Galaxy Discovery OWS YES FROM START
(default port= ----) YES o YES YES SLIDE BAR DATE - TIME YES
WiseNet Wave
YES -- YES YES

(default port = 7002)
* Video Viewer appearance and controls are determined by the developers of the 3™ Party VMS Integration & Plugin solutions. Galaxy Web-API Kit offers all features.

** Contact Technical Support for information on new or existing Plugins and VMS solutions.

unctions may vary by camera models. ontrols may vary by 3 Party developer of their solution.
1) F i b dels. (2) C | by 314 P devel f their VMS soluti

GENERAL NOTICES

» SYSTEM PRODUCT REGISTRATION:
Galaxy supports 3™ Party VMS via the DVR Support option which is enabled in System Registration by an Authorized Dealer and
according to the customer’s purchase agreement.
« 3" Party DVR option is available with Corporate and Enterprise product level registration.
(Professional-level = uses the Galaxy DVR (OEM PC-based solutions))
¢ You must also configure the Unit Count - per the customer purchase agreement.

»  CLIENT USER-RIGHTS TO CAMERAS @ THE VMS SYSTEM:
For certain VMS solutions the SG Client must have full user-rights to all cameras, while other brands may support limited rights. See
Chapter 2 for details.

» ENABLING VIDEO ON A “PER WORKSTATION” BASIS:
Viewing video must be enabled and disabled on a “per workstation” basis. See the related section in this guide for instructions.

» AUTOMATIC LIVE FEED FROM ARMED INPUT/DOOR:
Automated video pop-up requires a) the camera to be correctly linked to a hardware device and b) enabling of workstation options.

»  AVAILABILITY OF CAMERA CONTROLS & VIDEO CONTROLS:
Controls are available in Video Viewers based upon the 3™ Party development. Additionally, camera controls (such as PTZ, Iris, etc.)
may be dynamically disabled based upon type of camera or camera settings at the VMS unit for each video channel.

» MANAGING ASSETS:
Follow the VMS manufacturer’s instruction manuals for saving and backing up video assets (historic video files).

» NETWORK TIME SYNCHRONIZATION:
System Galaxy is NTS compliant. The VMS must use the same time-source as System Galaxy. Consult the manufacturer’s instructions
for your VMS to determine whether the unit can reside on a domain and how to apply time synchronization.
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Video Plugin Requirements

This is a list of the known requirements that apply to the System Galaxy integration with the video plugins. Use these
requirements for planning, installing, or trouble-shooting purposes. They are not intended as a substitute for following
instructions. Keep in mind that the manufacturer of the VMS may also have requirements that need to be met.

@ Always consult the manufacturer’s requirements and documentation.

@ For a full list of OS, PC, and System requirements for System Galaxy clients, see the System Galaxy Specifications Guide

® To prevent security issues, you should change the default port number set by the manufacturer.

GALAXY PRODUCT-LEVEL AVAILABILITY

SG 11.0.0.1 (or higher) PROFESSIONAL = CORPORATE | ENTERPRISE UNIT COUNT
3RD PARTY VIDEO PLUGIN SOLUTIONS -- v v DVR LIMIT MUST BE ENTERED
GALAXY OEM VIDEO PLUGIN SOLUTIONS v v v

NETWORK REQUIREMENTS

1. Network Time Synchronization: The Video System should be using the same NTS time-source as System Galaxy.
This requirement ensures the video timestamps will match the timestamps of the corresponding SG events.

2. Network Security: At the SG Server or Client Workstation(s), you must unblock the correct port number for the
Video System. This includes unblocking ports at switches and routers and creating exceptions in Windows Firewall
and your Security/Malware applications.

3. Network Performance: You must also meet requirements and best-practice for speed, bandwidth, peak demands,
and security. Also see your VMS manufacturer’s documentation.

4. Network Connectivity: You must know the correct IP address or URL address of the unit you are installing (i.e. IP
Address, DNS name, URL Address, or cloud address). Some addresses may include “https://” with the IP Address.

5. Security Permissions: You must give the appropriate user-rights to the login credentials that SG will use to connect
to the VMS. (For LENSEC PVMS, you must give user-rights to all cameras.)

GALAXY SYSTEM & WORKSTATION REQUIREMENTS
1. Before you can add the VMS and cameras to SG, you must have installed the unit and configured the cameras.

2. Video Plugin files: must be installed on every SG Client that will support video monitoring via on-demand or
auto-popup. Plugin files install in the VideoAPIplugins folder during Part-3 of the Galaxy Install Suite.

»  (for Example: C:\\GCS\System Galaxy\VideoAPIPlugins\Lensec...\ ).
» See the configuration chapter for details on your specific brand of VMS solution.

3. The GCS Web API Service must be running and configured to “start automatically”. The service is installed on the
main communication server.

4. In SG System Registration screen ...
» DVR Support option must be enabled (available in Corporate or Enterprise product levels)

»  Units field must have the correct number of units (per the customer purchase agreement).

Continue on next page ...
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In SG System Settings screen ...

»

»

»

General tab: the DVR ENABLED option must be “checked” at each client that needs video support.

General tab: the Does Not Support Monitoring option must be “unchecked” at each client if you want
the operator to manually command View Video from the Alarm Event screen.

Alarm Options tab: the Automatically Call-Up DVR Video option must be “checked” at each client if you
want the Video Viewer to automatically launch when an alarm event happens at a camera-linked device.

In SG Client Gateway Settings screen: the GCS Web API Service settings are automatically set according to
installation defaults. This can be edited if you decide to use a different port than the default 8000.

In Hardware > DVRs > Video API screen, you must select the appropriate brand of your VMS solution.

»

»

»

»

»

You must correctly add the port number, IP Address, VMS login credentials. Some brands may need to
include the “http://” prefix with the IP Address. If using a cloud system, you will need to enter the full
path to the cloud unit using the correct syntax — consult with the customer’s IT department and the VMS
vendor tech support as needed.

You must give the VMS Unit a unique name in System Galaxy.
You must click the [Test Connection] button to connect and import cameras*.

After you save the unit and camera list, it will appear in the Hardware Tree along with the cameras. You
may need to refresh the hardware tree by re-opening it from the View menu.

NOTE: changing or deleing a unit is done from the typical DVR Programming screen.

* User Rights: For certain VMS solutions (including Lensec), the System Galaxy login credentials (in the VMS Config screen)
will need to have full user-rights to all cameras at the VMS unit, before the video-feed will work properly. See chapter 2 for
list of names that require full rights. Solutions not listed may provide unique or partial rights.
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Chapter 2: Registering and Configuring the Video Plugin Solution

This chapter describes the registration and configuration of the VMS in System Galaxy.

Use the QUICK STEPS List to guide and validate your work. Each Quick Step has a correlating section in this chapter
with the instructions on how to perform the steps.

5:?' QUICK STEPS: ADD & SET UP THE VIDEO-PLUGIN
STEP 1. Install the VMS and connect and configure all cameras.
STEP 2. Install the client-side Video Plugin files (this is done during System Galaxy install Part-3%).
STEP 3. Configure the GCS Web API Service to start automatically'?, (refresh services).
STEP 4. System Registration®: the 3™ Party DVR option & DVR Limit must be set (PC restart required).
STEP 5. Configure the Client Gateway'® to connect to the Web API Service. (restart to initialize)
STEP 6. Enable ‘DVR Support’® option in SG System Settings screen (client-specific/restart to initialize).
STEP 7. Configure the Alarm Settings'® in System Settings screen (client-specific/restart to initialize).
STEP 8. Add the connection settings & login credentials to the VMS in Video Plugin screen.
STEP 9. Check the Hardware Tree to confirm the unit and cameras were added (refresh HW Tree as needed)
STEP 10. Link cameras to the hardware (doors/inputs) in the appropriate SG programming screens.
After initial system programming is completed, the SG Operator can begin using the VMS features.
@ See the System Galaxy DVR Guide for more information on using the Operator Commands.
@ See the VMS Manufacturer’s Guide for instructions on how to operate the 3™ Party Video Viewer
FOOTNOTES:

1

()
(3)
(4)
(5)

(6)

i
i
¥

:

EW'S] SEE: your Manufacturer’s VMS Documentation for instructions on how to install and configure the VMS and

Part-3 of the SG Software Install Suite installs the GCS services and client-side Video Plugins on the computer. Part-1 and -2 of the SG Install Suite must be
completed before part-3 on every computer using the appropriate choices, based on the role (i.e. communication server, database server, client
workstation). SG software installation is described in the SG Installation Procedure.

Only one instance (no duplicates) of the GCS ClientGW Service & Web API Service can be running.

System-wide Registration is done at Communication Server and set up according to purchase agreement. Workstation Registration is no longer needed.
Configuring Client GW connection parameters to the Web API Service only needs to be done once at the Comm Server.

The option to enable and disable the Video interface is found on the General tab of the System Settings screen. This option only affects the local client
workstation. You can enable Video at one workstation and disable it at others. When checked, the video interface and operator commands are operational.
When unchecked the Video programming screens are disabled at the local workstation. This does not affect .

Alarm settings, including the “Automatically Call-up Video on incoming alarm” must be configured at each and every workstation. These settings can be
uniquely different from one client workstation to the next.

- SEE: the System Galaxy Software Installation Procedure for instructions on how to install System Galaxy

1
i
i software. These installation instructions are found on the HELP module or online.

camera hardware or associated components.
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STEP-1 About the VMS Install and Camera Setup

1. The VMS unit and any camera configuration should be completed before you add it to System Galaxy.

2. You must create a login credentials to the VMS for the System Galaxy client. You must provide the
appropriate level of user-rights to the SG login credentials, which may vary from one brand to the next.

» LENSEC PROSPECTIVE: the SG Login needs user-rights to all the cameras.

E"'Mf SEE: the brand Manufacturer’s DVR Documentation for instructions on how to install and configure the DVR
and camera hardware or client-side components associated with branded DVRs.

STEP-2 Installing the Video-Plugin Files

Follow the important notes below:

o Plugin files are automatically installed on each client during part-3 of the SG software install.

o If you are installing a Video API Plugin that was not originally included with your version of SG, you may be
able to obtain and install the plugin files you need without upgrading SG. See your authorized tech
support to obtain the plugin files and determine if an upgrade is needed.

e Each brand of Plugin Files are installed inside the VideoApiPlugins folder. Each brand has its own subfolder
which is installed directly in the path of “C:\GCS\System Galaxy\VideoApiPlugins\”.

1 = | VideoApiPlugins
Home Share View
« v » ThisPC > Local Disk (C}) » GCS » System Galaxy > VideoApiPlugins
Utilities o MName - Date modified Type Size
v || VideoApiPlugins LENSECPerspectiveVMS 1/23/2018 214PM  File folder

LEMNSECPerspectiveVMS

The VideoApiPlugins folder (showing the Lensec subfolder for example.
Each brand would have their own subfolder under the VideoApiPlugins folder.

STEP -3 Verifying GCS Services

The GCS Web API Service is installed on the Galaxy Communication Server. As of SG 11x the GCS WebAPI Service is
installed to run/start automatically and therefore should be running once the installation is completed.

1. You can verify the GCS WebAPI Service is running by opening the Windows “Services” screen from the PC
Control Panel.

2. Scroll down to the GCS WebAPI Service and see that it is running and configured to start automatic.

NOTICE: If your version of SG does not default the GCS WebAPI Service to run automatic, then right-click the service and select
‘Properties’ from the menu. Set the startup type as “Automatic” and save your changes. Start or restart the GCS WebAPI Service.
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STEP -4 Registering System Galaxy for 3™ Party DVR Support

(Certified Dealer required) The Video Plugin support is enabled via the 3™ Party DVR option in the System Registration.

¢ New Installs: the 3" Party DVR option should be included in customer purchase agreement & registration code.

e Upgrades: the 3™ Party DVR option can be added to an existing system, or the DVR Limit can be increased with a new
purchase agreement and new registration code. Contact customer support for assistance

% Open the System Registration screen - from the SG menu Configure P Options » Registration » System.
1. In the System-Wide Features, you must enable the 3" Party DVR option.
M If your Video Plugin is a Galaxy OEM product, then check the Galaxy DVR option
M If your Video Plugin is a third-party product, then check the 3 Party DVR option

M Only enter a unit count in the DVR Limit field for 3™ Party; per the customer purchase agreement.

NOTE: You can register both 3 Party DVRs and Galaxy OEM DVRs if the customer has multiple DVRs/VMSs; or is upgrading
an existing system. Follow the customer’s purchase order.

2. Complete the normal registration process and enter the new Registration Code
3. Click [Apply] button, then click [OK] button.

4. Restart System Galaxy software application after system registration is complete.

FIGURE 2 - PRODUCT REGISTRATION SCREEN — DVR SUPPORT OPTION

System Registration
]
Curent System 1D: Registered System 1D: Created Date,/Time: Workstation Co
1686864626 1686864626 6/18/2013 12:09:48 PM 1 Enabled the 3™ Part DVR option.
_ Also, set the [DVR limit] to the correct number.
Customer Name: Authorized Galzay Dealer Name: Deal
GCS B00-455-5560
I Product Level:
’H Corporate 5
System-Wide Features: ‘Web Client Options
[¥] CCTV Cortrol [Clweb Ciert (ASF o]l  Enter the correct Registration Code.

il ] Photo 1D Badge @i
* Requires Cal

Card Data Import/Export

7] Event Log Oiput (RS-232/TCF After you have completed all other settings.

5G. Time & Atendance
User Status/ Who's In 10 I Badge Prirting Systfm:
Galaxy DVR [
Card Exch Inid A4
ity OV Colbtmetpee @
Alarm Panel Support Maximum Clients:
Guard Tour 5 li
ick the APPLY n.
Passback & Door Groups C ck the bUtto
[¥] Graphic Device Status Maximum Readers:  # Used:
ZP& :t ?ﬁ?msffpports . 16 ~| 10 Visit GCSOnlifle Web Redistration Site M
jometric Interface Suppo
Unlimited Card Capacity (600 only} Maximum Biometric Readers: Registratiorrode:
Access Rule Overide (500 only) ) T2RGFX5
Maximum D5|-Based Readers:
0 Last Registered Date/Time:
10/9/2014 2:51:26 PM
A 4
[ ok || cancel | fopy |

SUPPORT: Dealers may use the GCS Online Registration website 24/7, or contact customer service. A valid
maintenance agreement is required for upgrading systems. Dealer online logon is required.
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STEP -5 Configuring the Client Gateway Connection Settings

(optional) This section covers editing the Client Gateway Settings to change the port number for the Web API Service.

NOTICE: In SG 11.0.2 or higher, the Web Services Setting is defaulted to enabled and SG auto-detects the URL. The field remains
editable in case administrators need to change this URL or Port at some future time. If the default Port needs to be changed, then
the administrator must also update the appSettings config file also.

IMPORTANT:

» A master-operator login is required to change this setting.

» This is a system-wide setting and applies to all workstations in the Galaxy system. Only needs setting once.

R/

¢ Open the Client Gateway screen - SG menu Configure » Options » Client Gateway
1. The ‘Use Web Services’ option must be checked.

2. You can change the port number for the Web Services URL. The default is 8000 for http.

TIP: If you are using https, you can change the port to the default 8443 without having to edit the appSettings
file, since the https default port is already configured in the appSettings file. However, if you are using some
other port number (not 8000 or 8443), you will need to edit the appSettings file.

IMPORTANT: Be careful to preserve the syntax. There must be a colon (:) between the IP and Port number.

3. Click OK to save your changes and exit the screen.

4. If you changed the Port to a non-default value, then you must also update the appSettings file to match.
The appSettings file is in the C:\GCS\System Galaxy\OptionalServices\WebServices folder.
Open the file in Notepad and change the appropriate port number depending on whether you are using http
or https port (http 8000 vs https 8443).

IMPORTANT: Preserve the syntax. There must quotation marks around the Port number “nnnn”.

5. After you changed the port, you must restart System Galaxy software and refresh the Services ...
e Restart GCS Web API Service
e Restart GCS ClientGW Service

FIGURE 3 — CLIENT GATEWAY CONNECTION SETTINGS SCREEN — WEB SERVICE SETTINGS

Check the Web Services & Provide URL.
You can change the port number in this screen if
needed. Keep the syntax intact.

| |00z | In SG 11.0.2 and higher this option is defaulted to
checked and SG automatically detects the URL.

Client Gateway Connection Settings

IP &ddress: IP Fart:
El".l =Ty

Encryption Type:
AES w

Syztem [D Settings:
Syztem |D Port #:

Test

Syztem D

“wWeb Services Settings:

Use\Web Services

Web Services URL:

| http: Ao alhost 5000
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STEP -6 Enabling & Disabling Video Support (workstation-specific)

The “DVR Enabled” option controls the Video Support at the local client-workstation. This option must be enabled
regardless of which brand of DVR/VMS you are using.

o Enabled (check) = allows the Video Viewer to launch or pop open at the local workstation.

« Disabled (unchecked) = prevents the Video Viewer from launching or popping open at the local workstation.

IMPORTANT:

» Enable DVR option is ON (checked) by default; (disable it only at workstations where you want to prohibit video).
» A master-operator login is required to change this option in System Settings.

» These are workstation-specific settings and will not affect other workstations in the Galaxy system.

+** Open the System Settings screen - SG menu Configure » Options » System Settings
1. Select the ‘General Options' tab.

2. "Uncheck” the Does Not Support Monitoring option to allow the Event screens to display so that the
operator can 'view video' from Alarm Events at the local workstation.

3. Place a “check” in the DVR Enabled option to enable Video Support at the local workstation.
(Unchecked = disables Video Support (i.e. user cannot view video, and cannot add/edit a VMS Unit or cameras)

4. Click APPLY button to save changes.

5. Proceed to the next step to continue configuring Alarm Options (Automatic Call-up on Alarm);

Or click OK to exit System Settings. NOTE: if exiting, restart System Galaxy to initialize the changes.

FIGURE 4 — ENABLE DVR SUPPORT IN SYSTEM SETTINGS SCREEN

System Settings X
1 Badging Options CCTV Opticns Time § Attendance Optiona Guard Tour Options: Cand Data Replication Options
| (Genersl Optians Alam Options Report Optons Muiti-Media Options Pusdit Options: Database Options Cardholder Options. |
| Event Window Options Biometric Settings:
] Does Mot Support Moritoring Biometric System:
(@) Each loop has its own event window Manager BioBrdge ~

() Mll laops share a single event windaw

| Event buffec sze: 500 | Set up the General Options as needed:
- “check” DVR Enabled option.

- “uncheck” Does Not Support Monitoring
to support Viewing Video from the Alarm

IMonitoring screen.

E Show Hardwarne Tree on startup

Show Communication Control on stardtup
[+ Shew Events on statup

[ Phete Vedfication Enabled

[ Display Maintenance Expiration Waming Message

O
% g

2

]

[ ok ]| Cowe
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STEP -7 Automatically Call-up Live Video for Armed Alarms (workstation-specific)

The “Automatically Call-Up Video” option controls whether SG automatically calls-up video for a device-linked camera
(reader or input) when the device is both ‘armed’ and in the active ‘armed alarm’ state. However, there are additional
conditions that must be true, before the video will be called-up. See table below for a breakdown of the required factors.

e Enabled (check) = SG will launch Video Viewer and call-up live video from device-linked camera for ‘armed alarm’ event.

o Disabled (unchecked) = SG will never auto-call-up video for armed alarms.

Table: Auto Call-up Video for Armed Alarms = the 5 A’s

SYSTEM SETTING DEVICE PROGRAMMING AND CONDITIONS VIDEO
“Auto Call-up Option” CAMERA LINKING DEVICE PROPERTY STATE CONDITION RESULT
Is it Assigned? Is it Associated to device? Is it Acknowledgeable? Is it Armed? Is it Active? Is video called up?
True (checked) True (Linked) True (checked) True (Armed) True (Active/Alarm) | YES (all conditions true)
(unchecked) True (Linked) True (checked) True (Armed) True (Active/Alarm) NO (not assigned)
True (checked) (unlinked) True (checked) True (Armed) True (Active/Alarm) NO (not assoc.)
True (checked) True (Linked) (unchecked) True (Armed) True (Active/Alarm) NO (not Ack'd)
True (checked) True (Linked) True (checked) (Not Armed) True (Active/Alarm) NO (not armed)
True (checked) True (Linked) True (checked) True (Armed) (Idle/Safe) NO (not active)

Video is automatically called-up only if these 5 conditions are All True! If any condition is false, video is not automatically called.

IMPORTANT:

» A master-operator login is required to change this option in System Settings.
» This is a workstation-specific setting and will not affect other workstations.

» The ‘Automatically Call-up DVR Video’ feature will call video for cameras that are associated (linked) to an input or reader if they
are armed and set to require acknowledgement when an active alarm condition happens.

» Alarm Priority: Be aware that if you if you are using alarm priorities, that the live feed comes from the camera with the
highest priority, and not necessarily from the most recent incoming event.

+** Open the Client Gateway screen - SG menu Configure » Options » Client Gateway
1. Select the ‘Alarm Options’ tab.
2. “Check” the ‘Automatically Call-up DVR Video’ option to enable it. (Unchecked means the option is disabled.)

NOTE: the Pop-up on alarm option is optional. It allows SG to pop the Alarm Event window into focus when an armed
alarm happens, which will interrupt whatever the user is doing. The Video Viewer will auto-start and call-up video
regardless of whether this option is checked.

3. Click the APPLY button and OK button to save your changes.

4. Restart the System Galaxy software to initiate the changes.

FIGURE 5 — ENABLE DVR SUPPORT IN SYSTEM SETTINGS SCREEN

System Settings X
‘Auto Call-up Video’ is in the Alarm Options tab
Badging Options CCTV Options Time & Attendance Options . CheCkF:%d - enabled P
General Options Alarm Options Report Options Multi-Media Options, B |
e unchecked = disabled
Min  Max
Acknowledge alam priority range: _C' “9959 ] £41Pop up of alam
(] Allow Aghknowledge Al
Force response above priority: _ﬂ Allow Pelete command
: 0 Om ot In System events as Invalid Attempts
M teat b h:
FIRLER eRponee text fong! Pl [ Aufmaticaly Delete Acked & Restored Alams
) [ gfable Double-Click Acknowledge
Color Settings: [ Automatically Call Up DVR Video
Pending alam message: [ | :I' B4 Prevent Application Shutdown w/Pending Alams
r—pm |
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STEP -8 Adding a VMS Unit to System Galaxy

The Video System and Connection Information

PREREQUISITES

» The VMS unit and all the cameras must already be correctly installed /configured (including camera names).

» SG Login Credentials (Username/Password) must be created at the VMS Unit with the user-privileges to cameras.
(For LENSEC PVMS: the SG LOGIN must have full user-rights to all cameras at the VMS unit).

» The correct client-side video plugins must be installed, and the GCS Web API Service must be running.
» System Galaxy must be correctly registered for the 3rd Party DVR Support.

» The SG DVR ENABLED option must be checked (is System Settings Screen/General tab).

» The Web API Service must enabled and configured in the Client Gateway Settings screen.

» Brands will vary for programming requirements. Contact Tech Support for assistance if needed.

ADDING A VIDEO-PLUGIN VMS UNIT (and Cameras)

«* Open the Video Plugin Screen - from SG menu Configure » Hardware b DVR’s » Video Plugins
1. Select the appropriate Video Plugin brand (such as LENSEC, Panasonic, etc.).
2. Click the [OK] button to open to the VMS programming screen.

Enter a unique and meaningful name in the [Name] field (i.e. “Lensec PVMS 01”). FYI: This name will be displayed
elsewhere in SG, such as DVR Properties, Camera Programming, Camera Linking of the Reader & Input screens).

w

For OWS brand, you must choose the Web Services option and add the Service’s URL, Company, Stun Server, Recorder.
Enter the IP Address or DNS Name of the VMS Unit. (May require https:// to be included with IP Address.)
Enter IP Port Number if it should be different from the default value automatically shown.

N oo oo oA

Enter the User Name & Password (login credentials): The login used here must exist at the VMS Unit and must allow
viewing and controlling video and cameras.

8. Click the TEST and SAVE CONNECTION buttons, which will connect the VMS and import the cameral list.
9. Click SAVE SYSTEM DATA button to save the VMS connection settings and the camera names into the SG database.
10. Restart System Galaxy software as appropriate to initiate the system.

FIGURE 6 — VMS PLUGIN SCREEN & PORT# TABLE

B2 Select VM5 Type - O = Type of Video System Dflt Port Vendor Codes Viewer
Phug-ins LENSEC Perspective 8085 normal Lensec Viewer
Select the desired Plug-in and then dick OK Pick your brand Video Insight 7 (VI7) 9000 normal VI7 Viewer
LENSEC Perspective of Plugin here. DW Spectrum * 7001 normal DW Viewer

ox Iﬂ OWS Discovery OEM -- normal OWS Viewer
WiseNet Wave * 7002 normal WiseNet
Call Tech Support for assistance, as needed. * may require “https://” to be included with IP Address
£ LENSEC Perspective - o %

Ensure System Exists

Connection Information

Name:

LENSEC PVMS 01

IP Address: IP Port &:

CameraldNumber PtzSupported  Presets VideoSystemUid

Customer 1000 - Camera 1

Customer 1000 - Camera 2

Customer 1000 - Camera 3
Customer 1001 - Camera 4

Save System Data
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EDITING CONNECTION SETTINGS FOR AN EXISTING VMS UNIT

If you need to change the IP connection settings of a VMS unit after it has been added to System Galaxy, then you
must do it in the traditional DVR Programming screen.

+* Open the DVR Programming Screen - from the SG menu Configure b Hardware b DVR’s
1. Select the appropriate VMS UNIT in the [Select DVR] droplist
2. Click the [Edit] button in the DVR screen
3. Make the needed changes.
4. Click the [Apply] button to save settings.

FIGURE 7 — DVR PROGRAMMING SCREEN & TABLE

Select a DVR: Add
Lenzec PYMS 01 v E dit
Mame: 1D Mumber: St
Lensec PYMS 1 | |3 | Apply
Carcel
OWA Type: Wendor Code:
LEMSELC Perzpective W5 MHommal 0WVE [MORMALDWE]

Connection Settings:

P Addresz or DNS Mame: P Part #:
|212.11B.B.121 | |an=35 |

Security Settings:

Izer Mame:

| adrmin |

Paszward: Confirm Paszward:

Show Pazsword Characters

& Use the [delete] button to delete an existing Unit’s configuration.
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STEP -9 Checking the Hardware Tree for Imported Cameras

Cameras should have been imported when you added the VMS in the prior step.

PREREQUISITES

»  The DVR unit and all the cameras are correctly installed /configured (including camera names).

»  You must have added the NVR / DVR unit to System Galaxy (see prior section) and met all the requirements listed.
»  You must be able to connect to the NVR / DVR unit.

DS

% Launch System Galaxy and sign-in - the Hardware Tree should be showing the VMS you just added.

1. Click the [+] button to expand the “DVRs” list in the Hardware Tree, you should see all the cameras you
imported in the prior step.

2. Now you can start linking cameras to the readers / inputs as desired.

FIGURE 8 — HARDWARE TREE

Hardware Tree o x
+E§' test
o %5 DVRs

—'ﬂ_ Lensec Demo
----- BH Customer 1000 - Camera 1
----- Bx Customer 1000 - Camera 2
----- B Custorner 1000 - Camera 3
----- ¥ Customer 1001 - Camera 1
----- £ Customer 1001 - Camera 2
----- Bx Custorner 1001 - Carmnera 3
----- Bx Customer 1001 - Camera 4

See the SG DVR Guide for instructions on linking cameras to hardware, and on how to retrieve live or
recorded video using SG Operator commands.

@ See the VMS manufacturer’s documentation for instructions on how to use their VMS Viewer
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STEP -10 Linking Cameras to Hardware (Inputs & Doors

This section requires you to have already taken care of the prerequisites (listed below):

PREREQUISITES

»  The VMS unit and all the cameras must already be correctly installed /configured (including camera names).

»  SG Login (Username & Password) must be created at the VMS Unit with the appropriate user-privileges to cameras.
(For LENSEC PVMS: the SG LOGIN must have full user-rights to all cameras at the VMS unit).

»  The correct client-side video plugins must be installed, and the GCS Web API Service is running.

»  System Galaxy is correctly registered for the 3rd DVR Support.

»  The SG DVR ENABLED option is checked (is System Settings Screen/General tab).

»  If you are supporting Auto-Callup on Alarm, you must have enabled the option in System Settings.

» If you are linking a camera to an input, you must have configured the input to need acknowledging to support alarm callups.

LINKING A CAMERA (and Cameras)

++ Open the Device Properties Screen - from SG menu Configure » Hardware » Doors (... or Inputs)

1. With the device screen open, click the EDIT button.
2. Select the DVR Camera Settings tab.
3. Choose the VMS Unit and select the desired Camera.

4. Click APPLY to save the settings.

FIGURE 9 — DOOR PROPERTIES — Camera Settings tab

P B35 Test Contral Lini |40l Contiollers Edi
Cluster: 002, Cont: 001, Brd: 1, Sect: 1-0 | Apply | Reports | ™
Motes:
Feader Name: Labol Ertiancs Cancel Scheduled Actions
Feadsr Type HID ProsPro L
“Wiegand Standard
General Timing/Schedules Relay 2 Settings Alarm Options Pazshack wha's In Groupdlnterlack. Options CCTY Events
Acoess Rules Elevator Schedules Graphic: Syrbols DR Camera Settings
Select DVR: Select Camera:
Lensec PYIS O1 w | | Cugtomer 1000 - Camera 1 v

FIGURE 10 - INPUT PROPERTIES — Camera Settings tab

Port Type: Digital /0 Board [2 Inputs, 4 Outputs]
Clugt: 002, Cant: 001, B: 5, 5: 2.1: 01 Operatc
Input Mame: D10 Input 1 [Snibby Button)
ARM Schedule: = NEWER ==
Made: Marmal |rput i3 Show In Tree

Lirk ta 140 Groups  Options  CCTY Events  Graphic Symbols  D%R Camera Settings

Select DYVR: Select Camera:
Lenzec PWiS O b Customer 1000 - Camera 2 it
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