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Chapter 1: Overview of SG Interface to CCTV

SG CCTV Mini-Guide

System Galaxy allows the SG Operator to control video distribution via the external CCTV switch.
Readers and input devices are (associated) linked to the CCTV switch in System Galaxy. Then
reader events and inputs are mapped to the cameras and monitors. Once this is done, video from
a specified CCTV Camera can be displayed on the mapped CCTV Monitor when activity occurs at
its associated reader or input. Operators can manually demand video also.

FIGURE 1 - SYSTEM DIAGRAM:

System Galaxy
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List of CCTV Brands that Galaxy Supports

System Galaxy (SG) integrates with following CCTV brands.

CCTV Brands

e American Dynamics

e Blue Allegiant

o Kalatel

e Panasonic MUX
e Panasonic WJ-SX550A
e Pelco CM 9750-DT

e Vicon

CCTVSWITCH

E"F“ SEE: the CCTV Manufacturer’s Documentation for instructions on how to install and
configure the CCTV, cameras, or any client-side components associated with the CCTV.

O SUPPORT: Consult a Galaxy Representative for recent additions compatible.
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CCTV Features Listed

e You can add/connect multiple CCTV Switches to your system (site-wide)
e CCTV Monitors can be excluded/included for access on a per workstation basis.

e Link/map reader events and input devices to CCTV Switches, cameras and monitors to provide
operators with video for various reader and input activities.

e Galaxy supports programming the preferred camera positions for individual events and inputs.
e CCTV Monitor ‘hot buttons’ on the SG toolbar to allow operator to swap between video

e Operator commanded view of Web Cam — 1 web cam per device (reader, input)

e Operator commanded view of DVR Cam — 1 DVR cam per device (reader, input)

e Operator “manual” command of designated CCTV monitors — 1 mon per device (reader, input)

e Operator can request CCTV video from the incoming reader events — readers must be linked to
monitors/cameras in the system programming. Distinct events are configurable (i.e. door
forced & open too long, invalid attempt, duress, passback violation, valid access).

e Operator can request CCTV video from the incoming inputs events - inputs must be linked to
monitors/cams in system programming.

e Operator can request CCTV video from incoming SG ARMED ALARMS - Linked inputs must be
configured to trigger armed alarms in system.

IMPORTANT:

CCTV MONITOR HOT BUTTONS:

Hot buttons call the. confirm with Kevin if these are linked to the manual command monitor or take
the camera last used

SG ARMED ALARMS FROM INPUTS and READER EVENTS:

In order to trigger an armed alarm In System Galaxy (SG), the input or reader must be:
~ linked to an I/O Group
~ configured to require ‘acknowledgement’

~ bein the armed state
~ and become active

Alarm Priorities are configurable and determine whether alarms come in as they happen or are sorted
by order of priority.
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CCTV Requirements

This section covers the minimum requirements that apply specifically to the SG CCTV Interface.

REQUIREMENTS FOR THE GALAXY COMMUNICATION SERVER

1. the GCS CCTV Service should be set up to start automatically when the PC starts

2. the following Galaxy services must be running and ports must be open:

Name of Service Ports Used

GCS CCTV n/a

GCS ClientGW Port 5010
Port 4002

GCS Comm Port 4000
Port 3001

GCS DBWriter Port 4001

GCS Event Service Port 4003

3. the CCTV Switch must be able to connect to the Galaxy communication server
4. the connection type is either direct RS-232 serial connection or TCP/IP using a Lantronix

5. you must assign/match the alarm numbers from the CCTV System to the readers and inputs
during the mapping cameras in monitors in System Galaxy

GALAXY PRODUCT REGISTRATION REQUIREMENTS

1. System Galaxy must be registered for CCTV Support in order to function. CCTV Support
can be registered during the initial system registration or added at any time.

2. Registration must be performed by a certified Galaxy Dealer.

PRODUCT LEVELS CCTV SUPPORT

Professional NO
Corporate YES
Enterprise YES
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Chapter 2: Register & Configure the CCTV & Cameras

This chapter describes the registration and configuration of the CCTV feature.

5:” QUICK STEPS: SETTING UP THE CCTV INTERFACE

PART 1.

PART 2.

PART 3.

PART 4.

PART 5.

Registering System Galaxy for CCTV Integration

Enabling CCTV Support in Workstation Options

Adding the CCTV Switch& Connection Settings in System Galaxy
Adding the CCTV Camera Names in System Galaxy

Linking Cameras to hardware devices in System Galaxy

the CCTV and camera hardware or client-side components associated with branded CCTVs.

E”F“I SEE: the brand Manufacturer’s CCTV Documentation for instructions on how to install and configure

EIE 6|  SEE: the System Galaxy Software Installation Guide for instructions on how to install System
i Galaxy software. These installation instructions are found on the HELP module on CD 1 menu.
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Registering System Galaxy for CCTV Support

You can register System Galaxy for CCTV Support during the initial System Registration. However CCTV
support can be added at anytime to an existing system.

1) Open the Product Registration screen - from menu Configure> Options> Registration> System.

In the System-Wide Features, you will check the CCTV option to enable it.
M Check the “CCTV Support” option. Unchecked means the option is disabled.

Complete the normal registration process as needed
Enter the Registration Code

Click [Apply] button

Click [OK] button

2) Complete the workstation registration as needed

3) Restart System Galaxy software after registration is complete

FIGURE 2 - PRODUCT REGISTRATION SCREEN - CCTV SUPPORT OPTION

3

Product Level: Dealer Phone Mumber:
B comorate [ | 3018456600
System-VWide Features: Software Maintenance Settings:
[FCCTV G | Expiration Date:
Ll

[+] Card Data Import
Evert Log Output (RS-232/
5.G. Time & Attendance
User Status/ Who's In
Galaey DVR e CCTV Support = any supported brand
DVR Support Limi
Alam Panel Support M
Guard Tour

Passback & Door Groups

[+] Graphic Device Status Madmum Readers:  # |Jzed:
[ 508i & 502 Support 10 el [10

32920171 |

Madimum Version:

Corporate and Enterprise levels support CCTV.

SUPPORT: Dealers may use the GCS Online Registration website 24/7, or contact customer service.
A valid maintenance agreement is required for upgrading systems. Dealer online logon is required.
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Enabling CCTV Support per Workstation

You can enable (and disable) the CCTV Interface at each workstation individually through the Galaxy
Workstation Options screen. You may not want some workstations in the system to be able to start up
and view video from the Galaxy CCTV Viewer.

ENABLING CCTV SUPPORT AT SG WORKSTATIONS
1) Open the Workstation Options screen - from menu Configure> Options> Workstation Options

2) Inthe CCTV Options tab, you will check the CCTV Enabled option to enable CCTV. Unchecked
means the option is disabled and you will not be able to add CCTV systems to Galaxy.

3) Click the APPLY button and OK button to save your changes.

4) Restart the System Galaxy software to initiate the changes. (NOTE: see next section before restarting)

FIGURE 3 - ENABLE CCTV SUPPORT IN WORKSTATION OPTIONS SCREEN

General Options Alam Options Report Options Multi-Media Options Audit
Badging Options CCTV Options Time & Atendance Options Guard

[FIECTV Enabied CCTV Enabled option in the CCTV Options tab
e checked = enables the CCTV programming screens
e unchecked = disables the CCTV programming screens

Local Monitors:

Maonitor Name CCTV Switch

Moritor 01 {1) CCTV-SW-01 (1)

MONITOR Enabled option in the CCTV Options tab
e checked = adds a monitor command button to the SG toolbar
e unchecked = removes the monitor button from the SG toolbar
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Assigning a CCTV Monitor to a Workstation
After you have finished programming your CCTV switches, cameras and monitors, you must assign the

CCTV Monitors to the workstation(s) you wish to have control and view of the monitor. This is done in
the Workstation Options screen.

IMPORTANT:

» You must be signed on as a master operator to open or edit workstation options.

» You must have completed programming your CCTV switches, cameras, and monitors.

» Each workstation must have it's monitors mapped in the local Workstation Options screen.
4

Monitors are mapped to the workstation and not filtered by operator sign-on privileges.

*%* Open the Workstation Options screen, follow the menu selection Configure > Options >
Workstation Options.

1. Select the CCTV Options (tab)
2. the Enable CCTV checkbox should remain “checked”

3. The Local Monitors list will be populated with the list of all available monitors. “Check” the boxes for
the monitors you want to view from the current workstation. Leaving monitors “unchecked” means
they will not be viewable from this workstation by any operator.

4. Click Apply and OK to save changes.
5. Click YES to restart your software.

FIGURE 4 - ENABLE INDIVIDUAL MONITORS PER WORKSTATION

Workstation Options

General Ophions ] Alarm Options ] Report Options ] Multi-tediz
Cardhalder Options ] Cardhaolder Path Options CLTY Options

O kornitor 03 [3) SWITCH 01 (1)

[ konitor 04 [4] SWITCH 01 (1)
Fanitor 05 (5] SWITCH 01 (1)
[ Monitor 06 (5] SWITCH 01 (1)
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Adding a CCTV Switch

Once CCTV Interface is registered and enabled, you must program your switches.

¢+ Open the CCTV Switches screen, follow the menu selection Configure > Hardware > CCTV
Systems > CCTV Switches.

TO ADD A NEW SWITCH:
1. Click the ADD NEW button
2. Type in a NAME for your switch
3. Choose a CCTV type from the droplist
4. Select your connection type from the droplist (TCP/IP w/ Lantronics or Serial Com Port)

If using TCP/IP with Lantronics:
» Type the IP Address of the Lantronics unit you will use with the switch
» The port number should default to 3001

If using Serial Com port:

» pick the com port number you will be using

» Set the baud rate according to manufacturer's programming
» Set the parity according to the manufacturer’s programming

5. Set the machine name or IP Address of the computer running the GCS CCTV Service
(typically the Communication Server).

Click the APPLY button to save settings; a dialog box opens to let you set the camera count
Choose the number of cameras that are associated with the switch

Choose the number of monitors that are associated with the switch

Click OK to save settings

© N

You may need to refresh (re-open) your Hardware Tree to see your switch icon(s) in the
tree. Simply close the hardware tree and select View > Hardware Tree from the SG menu.
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Adding CCTV Cameras

Once you have programmed your switch, you must program your cameras.

+* Open the CCTV Camera screen, follow the menu selection Configure > Hardware > CCTV Systems
> CCTV Cameras.

In the CCTV Cameras programming screen you can add a new camera or edit an existing camera.

TO EDIT A DEFAULT CAMERA NAME:

Select the switch name

Select the camera name you want to change

Click the EDIT button

Change the camera name to something descriptive

You do not need to change the camera number unless it does not match the physical camera

position at the switch

6. the pan-tilt checkbox is only effective if your software have been designed to support it and
you have the correct hardware installed.

7. Click APPLY to save settings

ok wbd =

TO ADD A NEW CAMERA:

Select the switch name of the switch you need to add the camera

Click the ADD button

Type the camera name using something descriptive

Set the camera number to the physical position of the camera on the switch.

the pan-tilt checkbox is only effective if your software have been designed to support it and
you have the correct hardware installed.

6. Click APPLY to save settings

a bk wbn =

You may need to refresh (re-open) your Hardware Tree to see your camera icon(s) in the
tree. Simply close the hardware tree and select View > Hardware Tree from the SG menu.
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Adding CCTV Monitors

Once you have programmed your switch, you must program your monitors.

+* Open the CCTV Monitor screen, follow the menu selection Configure > Hardware > CCTV Systems
> CCTV Monitors.

In the CCTV Monitors programming screen you can add a new monitor or edit an existing one.

NOTE: if you added the monitors in the last step of the switch programming, then System Galaxy will
have already built your monitor list using default names (monitor 01, monitor 02, etc.).

TO EDIT A DEFAULT MONITOR NAME:

Select the switch name

Select the monitor name you want to change

Click the EDIT button

Change the monitor name to something descriptive

You do not need to change the monitor number unless it does not match the physical
position of the monitor

6. Click APPLY to save settings

aORroON=

TO ADD A NEW MONITOR:

Select the switch name of the switch you need to add the monitor
Click the ADD button

Type the monitor name using something descriptive

Set the monitor number to the physical position of the monitor
Click APPLY to save settings

a bR wbn =

You may need to refresh (re-open) your Hardware Tree to see your monitor icon in the tree.
Simply close the hardware tree and select View > Hardware Tree from the SG menu.
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Mapping SG Events to CCTV Cameras and Monitors

Once the Switches, Cameras and Monitors are added into System Galaxy programming screens, you
can map the SG CCTV Events to the desired cameras and monitors.

This is done by assigning a CCTV Switch, CCTV alarm number, and camera(s) to the input or
door/reader event. Then you will mapping the cameras to the desired CCTV monitors you want the video
to display on when the event occurs.

System Galaxy inputs and certain doors/reader events can be used to trigger a CCTV Events for a CCTV
Switch. When the event occurs, the assigned camera’s video is distributed to the assigned monitor(s).

NOTE: CCTV events are not bi-directional. They are generated or issued from System Galaxy to the
CCTV switch. System Galaxy does not receive events from the CCTV System.
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Mapping Inputs to CCTV Cameras/Monitors

+*» Open the Input Properties screen, follow the menu selection Configure > Hardware > Input
Devices. You must add your inputs in your controller properties screen first.

In the CCTV Events tab you can configure which camera is controlled by the input and map which
monitor(s) the camera’s image appears on. You can assign as many as two cameras to an input and you
can map each camera to as many as four monitors.

» Select the CCTV Events (tab)
» Select the CCTV Switch that you want the input to trigger alarms for.

FOR EACH CCTV EVENT YOU WILL SET THE FOLLOWING DATA:

» Alarm Number: the alarm number is the number that the CCTV Switch will use to
activate the its monitors. The alarm number you put in this field must match the alarm
number the CCTV system will use.

» Camera Number: this is the camera number the video will come from for this event.

» Position number: this is a code number for the position/angle that the CCTV system
will use to point a pan-tilt camera (if supported).

» Monitors: these four fields are the monitors you want the camera’s video to be
distributed to. These monitors would be divided among several workstations (security
desks) located throughout the building.

» Manual Commands and Web Camera: these work like the manual commands for
the reader/doors. See the next section for description of manual commands.

Link ta /0 Gruups] Options  CCTY Events l Graphic Symbuls] [WR Camera Settings]

CCTY Switch: |SWITCH 01 =l
Alarm # Camera #  Postion#  Monitor #s
5 i o R U
o o R U

g i i

M arual Command:

“Web Camera URL:
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Mapping Door/Reader Events to CCTV Cameras/Monitors

+» Open the Reader Properties screen, follow the menu selection Configure > Hardware >
Doors/Readers. You must add your reader ports in controller properties screen first.

In the CCTV Events tab you can configure which Event controls which camera and map which

monitor(s) the camera’s image appears on. You can assign as many as two cameras to an event and
you can map each camera to as many as four monitors.

» Select the CCTV Events (tab)
» Select the CCTV Switch that you want the reader/door events to trigger alarms for.

For each CCTV Event you will set the following data:

» Alarm Number: enter the alarm number is the number the CCTV switch will use to activate

the monitors. The alarm number you put in this field must match the alarm number the CCTV
system will use.

» Camera Number: enter the camera that the video will come from for this event.

» Preset: enter the number for the position/angle that the CCTV system uses to point a pan-tilt
camera (if camera is a PTZ camera).

» Monitors: these four fields are the monitors you want the camera’s video to be distributed to.

These monitors would be divided among several workstations (security desks) located
throughout the building.

CCTV Events can be assigned Up to 2 cameras and up to 4 monitors each (thus a total of 8
monitors can be controlled by an individual event).

» Click Apply button to save settings.

CCTY Events ]

CCTVY Switch: |wITCH 01 |

Alarm Camera Preset  Monitors Camera Preset  Monitors
Door Forced Open: |2_ |1_ IU_ |1_ |2_ ID_ IEI_ |2_ ID_ |4_ ’5_ ID_ ’U_
Open Too Long: l-_"'_ l'l_ ID_ I'I_ |2_ ID_ ID_ |2_ ID_ |4_ ’5_ ID_ ’D_
Irvvalid Attempt: |3_ |1_ ID_ |1_ |2_ |3_ lg_ |3_ ID_ |4_ ’5_ ID_ ’D_
Duress: ID_ ID_ ID_ ID_ IU_ ID_ IEI_ ID_ ID_ ID_ ’D_ ID_ ’n_
Pazsback Violation: ID_ ID_ ID_ ID_ ID_ ID_ ID_ ID_ ID_ IU_ ’U_ ID_ ’D_
Valid docess: i p o p (o [ p o p o
Manual Commatd: |1_ ID_ IS_
DR Camera: |1_
‘wigh Camera LIRL: |www.galax_l,ls_l,ls.cc-m
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» Manual Command: you can also map a camera and

monitor to the door/reader for manual control. The
operator can issue the command to ‘View CCTV’ by
right-clicking the reader icon in the Hardware Tree
and selecting the menu option. The video displays on
the preset monitor. If the monitor field is set to “0”
(zero), the operator can override any monitor at the
workstation by clicking it on the SG tool bar before
issuing this manual command.

» DVR Camera: you can assign a camera from your

DVR system to record video to your DVR when
events at this door/reader trigger a CCTV alarm.

» Web Camera: this is also a manual command that the

operator issues from the SG Hardware Tree. You
provide the URL of a web camera in this field. The
operator can issue the command to ‘View Web
Camera’ from the shortcut menu by right-clicking the
door/reader icon. The web page will open up inside
the System Galaxy software.

SG CCTV Mini-Guide

SG Tool bar

oo

|

Lobby (3)

SG Hardware Tree
Hardware Tree [

=B Building & (500]
+-[J8 Controllers
- J;“ Doors/Readers
Cluster: 001
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+-ll5 Elevators
=B Building B [500)
+-[J8 Controllers
- J;“ Doors/Readers

% Clugter; O

=g COTV Spstems
- Mg SWITCH 7
Camera 07
Camera 07
Camera 0]

CEREPERROE
[l
=1}

Loop: [
L
Reader Mame: P
FReader Type |—
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CCTYE
Lock
Unlock,
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Disable \
Enable
Relay 2 OFf

Wigw CCTY
Wiew Web Camera

Camera 0y = i
Camera 0 Properties
Camera 05 1=
CCTV Pan - Tilt - Zoom Control ]
Fan & Til Zoam

Mear Far
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SETTING THE CCTV SERVICE TO RUN AUTOMATICALLY

+¢ Click on the Windows® start button and navigate to Programs > System Galaxy > Utilities
and select the Service Manager.

» Select the GCSCCTV service in the Service Manager screen
» Click on the Properties button

- GCS Service Manager (XP5150-TW) M=
Ltilities  Help
Service Description Statusg Shart
@ GrsamPrl Stopped 4
@ GCsalphaCom Stopped
@ GoscoTy Stopped
Q) GCSClientGiw Runnind e
0 GCSComm Running
0 GCSDataloader Stopped
@ GrsDEwiter Running Stap Al

» Set the Start Type to “Automatic”
» Click OK button to save settings

Service Properties - (GCSCCTY)

Pathnarme:
|"E:"~F'rn:|gram FilezhSupztemn GalawhGCSCCTY exe'

[ ependencies:

|.-’-¥.utn:-n'|atin::

» Select the GCSCCTV service in the Service Manager screen again
» Click on the Start button; the status indicator on the CCTV Service will turn green.

EEX

- GCS Service Manager [XP5150-TW)

Lltilities  Help
Service Dezcription Statuz
@ GrsamPn Stapped
@ GCsaphaCan Stapped
@ coscoTy Stapped
) GCSClentGw Rurning Pranerties |
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CONFIRMING THE CCTV SERVICE CONNECTIONS

When the CCTV Service starts, the CCTV icon will display in the Windows® task tray.

LG

++ Double-click on the CCTV icon 4 to open its connection status window.

The first tab shows the status of the connections to the CCTV Switch.

==

= CCTV Connections - GESCCTY
File Setup Wiew Help

Client Gateway:

/“ CCTY Connection tatus Messages -
— ID# | Protocal Status Details Address Statuz Message

SWITCH O 1 Dizconnected 192.126.0.101.3...  TCR/IP atterpting to connect...

The second tab shows the status messages which are logged from the CCTV Service. You can
use the Connect/Disconnect button to force a connection attempt or to disconnect from the GCS

Client Gateway.

B=(E3

w5t Status Messages - GESCCTV
File Setup YWew Help

CCTE Connections SlatUSMESSE'QESI

—_——— = arnm T hread stopped.
12/7/2007 4:39:.01 PM: CCCTWCommThread starked,
12/7/2007 4:39:01 PM: Atternpt to cornnect timed out without establishing a connection.
12/7/2007 4:38:40 Ph: CoreThread started.
12/7/2007 4:38:40 PM: Service Started.

The Setup > Configure menu allows you to set the Data Source for the CCTV Service to the
database. This should be correctly set from the install if you did a full installation from the CD

using the default database technology.
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Appendix E: Keywords and Terms

Table 1 Document Keywords

Keyword/Term | Description

“associated” or | A door/reader/input that has been configured with a DVR unit and Camera in
“linked” device | its property screen; when the associated device generates and event, a SG
menu option can be selected to retrieve the video feed from that message’s
timestamp.

CCTV Closed Circuit Television; i.e. the physical CCTV unit (acronym).

CCTV Interface | The CCTV Interface is the System Galaxy software feature that allows
interaction between the Access Control System and the CCTV System.

GCS Galaxy Control Systems (acronym).
GCS CCTV System Galaxy uses services to handle message transmission between the
Service CCTV switch, SG client, server, and database. The service must be running

in order to actively integrate with the CCTV equipment.

Communication | Loop Communication Server is the PC that hosts the System Galaxy software
Server or LCS | and communicates with the Loops/Controllers and the System Galaxy
Database for SG 6.x Software.

SG System Galaxy (acronym); Refers to the SG System (its hardware and/or
software).

SG Workstation | A PC that runs to System Galaxy, but is not the LCS or SG Server.

Mapping The term mapping refers to the process of configuring which cameras are
linked to which device in the System Galaxy software.
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