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Introduction to Badging with Card Exchange 7  
 
This manual covers the basics of installing, configuring, and using the new badging software. 
 
System Galaxy offers a new card/badge interface built with CEInside (Card Exchange) v6.03.  
System Galaxy has integrated the Card Exchange Badge Designer and Print Engine into the SG 
software.  

Overall Requirements for Card Exchange: 
 
NEW INSTALL REQUIREMENTS: 

 You must choose to install either the (a)Full Installation or the (c) Badging Workstation when running 
Part-3 of the SG 10.3 Galaxy Installer from DVD-1.   

• The Full Install option installs a communication server (including GCS Services, event logging/ 
monitoring, the badging capability.  

• The Badging Workstation option  and badging workstation options includes badging software 
onto the desired workstation (i.e. either).  The install will put down a CEX folder inside the 
System Galaxy folder which includes your CEX install .bat file. 

 You must install and configure the badging printer/printer driver correctly on the computer running 
the badging client software.   

• The printer options must be set to support printing the type of cards you will use.   

• The printer driver must be setup to support the features or specifications needed. 

• Galaxy sells and supports the MagicCard line of printers.   

• Galaxy also supports an array of other leading badge printers.  When planning for badging, 
you should verify the chosen printer will support the features you desire. Contact Galaxy 
Control Systems Technical Support for details. 

 You must run the Card Exchange install.bat file to perform the correct installation of Card Exchange.   

• The install.bat file is put down in the System Galaxy folder:  
C: GCS\System Galaxy\CEX\Install\install.bat 

• Do NOT run the Card Exchange setup file separately. Galaxy does not license a standalone 
version of the Card Exchange product. 

• When you run the install file, the installer program installs the CEX-7 software inside the 
System Galaxy folder and also places the badge design templates and data folder under the 
System Galaxy folder. 

• Ports 4747, 4748, and 4749 must be unblocked for the print server to operate (these ports 
should automatically be opened by the installer.  

• The license file requires port 5093 to be open/unblocked on the server, which is automatically 
opened by the installer.  
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UPGRADING PRE-EXISTING VERSIONS OF CARD EXCHANGE: 
 
 

 To ADD or UPGRADE BADGING on an existing System Galaxy v8 client: 
If the workstation/PC had other badging software (such as EpiBuilder), those templates are not 
compatible with Card Exchange and no method of conversion exists. You must to redesign your 
badge templates in the Card Exchange Designer after completing your upgrade/installation. 
In order to switch over to the Card Exchange software, you will upgrade the existing SG 
Communication server by running all three parts of the installer : 
(and you will run all the install modules of the or no badging software, then you will run the GalSuite 
part-3 to upgrade the software and follow the install instructions in the next section, beginning with 
step 2. 

 
  
 For an existing SG client that is already licensed for the previous badging software: see the 

System Galaxy Software Install and Software User manuals that cover your badging software.  
Galaxy continues to support the previous software under the valid license agreement you purchased. 

 
 SG 9 integrated with Card Exchange 4 ~ the same upgrade instructions apply to 

upgrading to CEX-7 as did with CEX-6.  
 
 SG 10.0 integrated with Card Exchange 6.  You must run Galaxy install Part-3 and allow 

the Galaxy Installer to uninstall the old v6 and then install  } 
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Installing and Configuring the Badging components 
 
STEP ACTION 

1 INSTALL SYSTEM GALAXY SOFTWARE 

You must correctly install all parts of the System Galaxy software (1, 2, and 3). 
 Part 1 – install prerequisite components ~ required 
 Part 2 – install MS SQL Components ~ required.  If you are installing a workstation 

that is part of a distributed solution (i.e. separate database server), you will install only 
the MS SQL Native Client components.   

 Part 3 – Installing the System Galaxy software for a client workstation that 
supports badging.  Two possibilities are available: 

a) Option A – is a complete install: this includes System Galaxy 
software and badging components along with core services.  You will 
only choose this if you are installing a Communication Server. 

b) Option B – is a client only workstation install: this installs System 
Galaxy software and badging components. 

2 INSTALL THE BADGE PRINTER DRIVER 
 Install the printer driver according to manufacturer’s instructions and perform a test 

print using the desired print settings. 

3 INSTALL CARD EXCHANGE INSIDE SOFTWARE AND TEMPLATES 
 Go to C: Program Files\System Galaxy\CEX and run the “install” file to begin the 

installation. 

 The Card Exchange install will run as follows: 

a) the CEX software installs in the System Galaxy/CEX folder 

b) All the templates and data folder are installed in the System Galaxy Badging 
at the root of the C-drive. Note: if you are running VISTA® you must store your 
System Galaxy photos directory to the new badging folder just created C: 
DRIVE. 
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Registering System Galaxy for Badging 

You must perform the Registration according to purchase order.   

SYSTEM REGISTRATION:   

 At the Communication Server, start System Galaxy and logon as a master operator. 

 Open  the workstation registration screen from the Galaxy menu:  
Configure > Options >Registration >Registration Wizard (or System Registration).   

 Also perform the local workstation registration for this server as appropriate.  If the 
main communication server will not host the badging station (typical), then do not register 
badging options at this computer. 

IMPORTANT: System Registration is done before the Workstation Registration.  The system 
registration registers the database and extended features according to purchase agreement.   
IMPORTANT: the databases/database server, and communication server/core services must be 
running and online during system registration in order to get a valid registration code. 

Refer to Chapter 5 of the SG 8.3 Software User manual for detailed information about 
System Registration. 

WORKSTATION REGISTRATION:   

 At the badging workstation PC, start 
System Galaxy and logon as with a 
master operator sign-on. 

 Open the Workstation Registration 
screen from the Galaxy menu:  
Configure > Options >Registration 
>Local Workstation. 

 Register the badging features 
according to the customer 
purchase agreement.  

IMPORTANT: the databases/database 
server, and communication server/core 
services must be running and online 
during system registration in order to get 
a valid registration code. 

Refer to Chapter 5 of the SG 8.3 User 
manual for detailed information about 
Workstation Registration. 
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Setting Workstation ‘Badging’ Options 

The Workstation Options must be set up to use the correct Badging Software  

 At the badging workstation PC, open the Workstation Options screen from the Galaxy menu:  
Configure > Options > Workstation Options. 

 Select the ‘Badging Options’ tab, and set Card Exchange Inside as the Badge System type. 

 Click the [Browse] button and go to C:\ System Galaxy Badging  

 Click OK to set the path, and click APPLY to save the configuration.  

 Restart System Galaxy to initiate changes. 
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Operating the Card Exchange Badging/Print Server 
 
The card exchange print server and badging software is very simple to use. The following sections 
provide simple steps to starting and using the Print Server and Badge Designer software. 

Starting the Card Exchange Print Server 
 
You can start the Card Exchange software from inside System Galaxy (toolbar):   

 Open System Galaxy from the desktop shortcut or thru the Windows Start menu: 

 Start® > Programs > System Galaxy > System Galaxy 

TIP: You can set up Card Exchange to automatically start when the computer boots up. This is done by 
placing the Card Exchange Print Server in your Programs Start folder. 

 
 a Windows® application console opens when the print server starts up.  

 
 

IMPORTANT: If the text in the Print Server console is red, this means you already have a print server 
running. Close any Print Server session that has red text; it will not execute print jobs. 

 
 

 The Card Exchange icon will display on the task tray (XP only) when you minimize the 
windows operating shell. Windows-7 OS does not display services on the task bar. 

 Right-click on the server icon to get to the Card Exchange menu 
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Stopping the Card Exchange Print Server 
 

 Right-click on the server icon to get to the Card Exchange menu 
 

 
 

 Choose ‘Stop print server’ option from the context menu. 
 

NOTE: you can click the red-x in the top right corner of the print server console window to close and 
stop the printer if it is open. Otherwise you must stop it from the menu as shown. 

 
 

IMPORTANT: it is not recommended to stop the print server while cards are printing. 
 
 
 
 
 
 

Showing the Card Exchange Print Server 
 

 Right-click on the server icon to get to the Card Exchange menu 
 

 
 

 Choose ‘Show print server’ option from the context menu. 

 The windows operating shell will re-open 
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Setting up the Badge Printer 
 

 Right-click on the server icon to get to the Card Exchange menu 
 

 
 

 Choose ‘Configuration > Printer options’ from the context menu. 

 The Printer Options window will open allowing you to choose your badging printer. 

NOTE: From this window, you can also set timing delays and Mag-encoder settings. 

 

 
 

 Click OK to save settings. 
 
IMPORTANT: The badge printer driver must already be installed. 
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Setting the Badge Printer Properties 
 

 Right-click on the server icon to get to the Card Exchange menu 
 

 Choose ‘Configuration > Printer properties from the context menu. 

  
 

 The Printer Properties screen (for the printer you selected in the previous step) will open 
allowing you to set up your badging printer properties. 

 

 
 

 Click OK to save settings. 
 
IMPORTANT: The badge printer must already been selected as the default printer. 
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Setting up the Photo Capture driver 
 

 Right-click on the server icon to get to the Card Exchange menu 
 

 
 

 Choose ‘Configuration > Photo options’ from the context menu. 

 The Photo Options window will open allowing you to choose your capture device. 

NOTE: from this window you can also set other related options. 

 

 
 

 Click OK to save settings. 
 
IMPORTANT: The photo-capture driver must already be installed. 
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Creating Badges with Card Exchange Manager 
 
Card Exchange Manager is the badge designer. Some initial setup is required. 
 

STEP-1  Starting the Card Definition Manager 
 

 Right-click on the server icon to get to the Card Exchange menu 

 
 

 Choose ‘Configuration > Show card manager’ from the context menu. 

 The Card-Definition Manager window will open allowing you to set up your badge design 
templates. 

 

 

 You can change the order of the list using the move up and down buttons. 

 You can edit an existing template or add a new badge design. 

 You can check any template you want to show up in System Galaxy’s badge design list. 
Unchecking a template will not delete it, but it will not be available in System Galaxy. 

 

NOTE: there are predefined templates in the list. These templates are “checked” by default 
and may be included when you import badge designs into the System Galaxy software if you 
leave them “checked”.  These can be used as starting templates for your badges and you can 
rename them as you like.  You can also delete them from System Galaxy after an import, if 
you desire.  
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STEP-2  Adding a Badge Design via Card Definition Wizard 
 

 Start the Care Manager as described in the previous step. If the print server is not running 
on the icon you must start it from the System Galaxy toolbar button. 

 click [ADD] button on the Card-definition manager window to open the Card Definition 
Wizard window. 

CREATE A BADGE DESIGN NAME 

 Type a descriptive name for your new template 
 Click NEXT to continue. 

 
 

CHOOSE TO CREATE THE BADGE VIA THE WIZARD 

 
 Select ‘Use STEP by STEP wizard’ 
 Click NEXT to continue. 
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SET UP THE BADGE TYPE & LAYOUT 

 
 Select the type of card  (SINGLE-SIDED or DOUBLE-SIDED as desired) 
 Select the orientation of the badge (Landscape vs. Portrait as desired) 
 Click NEXT to continue. 
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CHOOSE THE DATABASE CONNECTION (MANDATORY) 

 
 You MUST select ‘YES connect to a database’ (REQUIRED) 
 Click NEXT to continue. 
 

 
 
 Select ‘Connect to another database’ (MANDATORY) 
 Highlight the connection type (MANDATORY) – you can choose one of the connection 

types as desired.  You must select one of the two options listed. 

 “SysGal Blob Connection” (TYPICAL)  
 SysGal Connection (optional) 

NOTICE: if you are not capturing photos in Galaxy cardholder enrollment, then choose the typical 
Blob connection type.  
NOTICE: SysGal Blob Connection is the typical choice. System Galaxy is configured to store the 
main photograph as blob data.   
You can set SG to use photograph_filename in Galaxy’s System Settings if you do not wish to store 
blob data/ or if database size is a consideration for your system. If you upgraded from an older system 
that did not use Blob data, you can use the Synchronize Utility in Galaxy to convert your photo files to 
blob data . 

 Click NEXT to continue. 
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ADD DESIRED DATA FIELDS TO THE BADGE  

 
 “check” the combine first/last name (shortcut) if you wish to always have these fields on the 

badge.  

NOTE: If you are enrolling the first and/or middle names in Galaxy, but do not want them 
displayed on the badge, then do not check this option. Instead use the listview to locate FIRST 
and/or LAST names and check them individually. 

  “check” each individual field that you wish to add to the badge; 
 Department, Employee ID, DOB, etc. 

IMPORTANT: DO NOT check the MainPhoto from this list. 

 Click NEXT to continue.  
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ADD A PHOTO / SIGNATURE TO THE BADGE (OPTIONAL) 

 
 “check” the Add a Photo if desired and select ‘MainPhoto’  

NOTE: you can leave this unchecked if you are not actually using photos for this badge. 

 “check” the Add Signature if desired and select it  

NOTE: you can leave this unchecked if you are not actually using signatures for this badge. 

 
 Click NEXT to continue.  
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ADD A BACKGROUND IMAGE TO THE BADGE (OPTIONAL) 

 
 Choose a background color or image as desired (if you choose neither, the background 

will be white.  You can add an image later if you desire).  
 Click NEXT to continue.  

 
 

ADD A LOGO  TO THE BADGE (OPTIONAL) 

 
 Choose a LOGO image as desired (you can add an image later if you desire).  
 Click NEXT to continue.  
 

 
 



 SG Badging w/ Card Exchange Inside – Quick Guide 

  Page 22 of 32  

ADD A BARCODE TO THE BADGE (OPTIONAL) 

 
 “check” the  ‘Add Barcode’ only if desired  
 Configure the options as needed for your barcode implementation  
 Click NEXT to continue. 
 

 
 

AUTO-START THE DESIGN EDITOR AFTER WIZARD COMPLETES  

 “check” the  ‘START DESIGNER’ option to allow for adjusting your layout  
 Click FINISH to continue. 
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ADJUST LAYOUT OF FIELDS ON THE BADGE  

 
After the Editor opens, you can see that the fields you chose are automatically populated on your 
badge layout.   
 

 Use your mouse pointer to grab the fields and move them around, arranging them on 
the layout as desired.   

NOTICE: You can map the picture object to a default image as desired. The “default image” 
will print if a main photo is not saved for a cardholder.  If you do not map a default image and 
no main photo is saved, then nothing will print for the Photo field.  

 To set a default image for the photo field, right-click the photo and click the folder button 
and browse to the default image.   

 
 SAVE YOUR CHANGES !!!.  
 You can close the Designer using the File menu to exit. Close the Card Definition Manager if 

you do not wish to make another template. 
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STEP-3  Importing the New Badge Design into Galaxy 
 
In System Galaxy, you must import the badge designs from the Card Exchange Badge Designer 
screen.   

 

IMPORT THE BADGE DESIGN INTO GALAXY 
  

 Open System Galaxy and login as a master operator. 

 From the menu, select Configure > Cards > Badge Layout Designs. 

 In the Badge Layout window, click the [Import Card Definitions] button and wait for 
System Galaxy to import the list of templates available.  The card definitions you created 
and that are checked in the card definition list (see previous steps) will appear in the list. 

 The customer field is used for systems running the Galaxy Web Module.  You only need 
to set this if you are defining customers. NOTE: the customer must be defined in System 
Galaxy before it is available for use in this field. 

Refer to the System Galaxy Software Manual for information on how to assign and print badge 
templates to cardholders – found in chapter 17 of the Software Manual. 
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STEP-4  Assigning a Badge Design to a Cardholder 
 
In System Galaxy, you must assign the badge design to the cardholder in the Cardholder screen.   

 

ASSIGNING THE BADGE DESIGN TO THE GALAXY CARDHOLDER 
  

 Open System Galaxy and login as a the appropriate operator. 

 From the menu, select Configure > Cards > Cardholders. 

 Select the Card/Badge Settings tab 

 After configuring the name, card ID and necessary access privileges, choose the desired 
badge design from the BADGE DESIGN droplist. 

 Click APPLY to save settings 

 Once you save the cardholder, you can PREVIEW or PRINT the badge from the 
Cardholder screen 
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Editing Badges with Card Exchange Manager 
 
Card Exchange Manager also allows the user to manually edit badges without using the wizard.  
This is beneficial if you only need to make small changes after creating the badge through the Wizard. 
 

 Right-click on the server icon to get to the Card Exchange menu 

 
 

 Choose ‘Configuration > Show card manager’ from the context menu. 

 The Card-Definition Manager window will open allowing you to set up your badge design 
templates. 

 Click EDIT for the badge you wish to edit. 
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SETTING THE DATABASE CONNECTION FILE 
 

 You should already see the Database Connection file for the System Galaxy database 
called “SysGal Connection.dtd”.   
 If you need to change the connection values such as the name of the database or the 

login and password, etc., you can click the EDIT button. 
 If you located your connection file elsewhere you can use the […] browse button to 

locate to the file. 
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OPENING THE BADGE LAYOUT SCREEN (DESIGNER) 
 

 You must type a name for your new badge template into the name field. 
 Check only the options that apply to your card printing/printer setup. Uncheck those that 

do not apply. 
 Enable printing (this should be checked) 
 Enable magnetic encoding  (only for mag-stripe) 
 Print front  (this should be checked) 
 Print back (if you are printing the back) 
 Print back first (if your printer setup requires this) 
 Rotate front 
 Rotate back 
 Send to printer as a bitmap (file format .bmp) 

 Click the [Create] button to open the designer.   
 If you need to change the connection values such as the name of the database or the 

login and password, etc., you can click the EDIT button. 
 If you located your connection file elsewhere you can use the […] browse button to 

locate to the file. 
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USING THE BADGE LAYOUT SCREEN (DESIGNER) 
  
The badge layout screen has several menus, toolbars and panels to help you design a badge: 

1. Menu bar  (you can access the software help from here) 
2. File toolbar, object toolbar, text format toolbar, layout toolbar 
3. Tools bar (docked vertically on left side) 
4. Card object tree panel (panel is docked on left next to the Tools bar) 
5. Workspace pane (center where the card is displayed) 
6. Variables panel and Functions panel (where user builds data fields for the card) 
7. Context menus (you can reach the context menus by right-clicking on the objects on 

the card layout (workspace) or items listed in the card object tree. 
 

 You must add objects to your badge template:  these are created from one of two places. 
 the Tools panel: add static objects (static means not connected to the database 

field – will not change dynamically – will remain the same for all cards with this design 
(i.e. a background, a logo, lines or shapes, static text, etc.) 

 the Variables panel: add dynamic objects  (dynamic means the field is mapped to a 
database field – will change dynamically based on individual cardholder data – it will 
display in the designated position on all cards with this design (i.e. a last and first 
name, department, card ID, employee ID, etc.) 

IMPORTANT: you will decide which fields you need as dynamic fields. These fields will appear 
in the mapping tab after they are defined.  You must have the correct connection file (set up 
in previous step) in order to link to the database fields you need. 

NOTE: enhance dynamic objects with operation you build from the functions panel 

 
 
 

WARNING: if you close without saving your changes you will loose your intended settings.  The CEX close 
confirmation message asks you if you want to CANCEL your changes when you close. If you click YES you will 
dump your changes. See the ExchangeIT Designer Help screens for details on how to create variables with the 
variable editor.  Get to the help from the software menu or from the Windows Start menu >Start > Programs> 
ExchangIT >System Help 

3 4 5 6 

 1 & 2 
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USING THE MAPPING SCREEN (DESIGNER) 
  
The Mapping tab is visible after you have added the dynamic fields and saved your card out.  Each 
dynamic field will display with the appropriate options available. The mapping screen allows you to 
connect or edit the connections has several menus, toolbars and panels to help you design a badge: 
 

2. Card object tree panel (panel is docked on left) 
3. Data object connections editor (appears on right) 

 
 You will notice that the fields that display are based on the type of data object you are 

selecting from the object tree.   
a) All objects have a type of data field  
b) and a database selection droplist 

 
 You can edit additional attributes like truncating leading zeros or formatting options 

depending on the type of data displayed in the field.   

 Click the FINISH button to save changes! 
 

 
 
 

 
 
 
 

WARNING: if you close without saving your changes you will loose your intended settings.  The CEX close 
confirmation message asks you if you want to CANCEL your changes when you close. If you click YES you will 
dump your changes. See the ExchangeIT Designer Help screens for details on how to create variables with the 
variable editor.  Get to the help from the software menu or from the Windows Start menu >Start > Programs> 
ExchangIT >System Help 

1 
2 

a 

b 
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EDITING THE PHOTO VARIABLE MAPPING (DESIGNER) 
  
In System Galaxy, the photograph location for cardholders is stored in the SysGal database.   

 A default photo field is created as a part of the installation. 

 Once you add the PHOTO variable to the card you can edit it in the mapping field – 
however it is important that you leave the database column value set to 
‘PHOTOGRAPH_FILENAME (SysGal)’.   

 You must also let the Image options to indicate that the ‘database column points to the 
image file. Do not select ‘contains image’.  SysGal does not store the image it only 
points the image path. 

 It is recommended to use the aspect ration of 3 and 4 as shown below. 

 Click the FINISH button to save changes! 

 
 

WARNING: if you close without saving your changes you will loose your intended settings.  The CEX close 
confirmation message asks you if you want to CANCEL your changes when you close. If you click YES you will 
dump your changes. See the ExchangeIT Designer Help screens for details on how to create variables with the 
variable editor.  Get to the help from the software menu or from the Windows Start menu >Start > Programs> 
ExchangIT >System Help 
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USING THE BADGE DESIGN IN SYSTEM GALAXY 
  
In System Galaxy, you must import the badge design list from the Badge Definition screen.   

 Open System Galaxy and login as a master operator. 

 From the menu, select Configure > Cards > Badge Layout Designs. 

 In the Badge Layout window, click the [Import Card Definitions] button and wait for 
System Galaxy to import the list of templates available.  The card definitions you created 
and that are checked in the card definition list (see previous steps) will appear in the list. 

 The customer field is used for systems running the Galaxy Web Module.  You only need 
to set this if you are defining customers. NOTE: the customer must be defined in System 
Galaxy before it is available for use in this field. 

Refer to the System Galaxy Software Manual for information on how to assign and print badge templates to 
cardholders – found in chapter 17 of the Software Manual. 
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